几个关于 iBus 输入法的记录

Mendely 的标注功能只支持 iBus 的中文输入,被迫从 Fcitx 改成 iBus。遇到一些问题,这里记录备忘。

Sunpinyin 无法打开首选项

Linux mint 切换输入法还是很简单的,Fictx 和 iBus 一键安装。系统设置 –> 语言 –> 输入法 –> 简体中文 点击安装即可。切换需要重启系统。

在终端中输入

1
ibus-setup #设置 iBus

点击 Sunpinyin 首选项,报错如下:

1
2
3
4
Traceback (most recent call last):
File "/usr/share//ibus-sunpinyin/setup/main.py", line 42, in <module>
import ibus
ImportError: No module named ibus

提示没有 ibus 模块,网上搜到的解决办法如下:

https://ubuntu.pkgs.org/14.04/ubuntu-main-amd64/python-ibus_1.5.5-1ubuntu3_all.deb.html 下载deb安装即可。或则从 这里 下载。

使用ibus-libpinyin

相比 ibus-pinyin ,ibus-libpinyin 更新一些。可能会更好。源码地址:

https://github.com/libpinyin/ibus-libpinyin

安装很是费劲,最后更新到 IBus 智能拼音 1.9.3 后居然直接不能用来,使用 apt 安装的是1.7.3 (mint 18.3)。

安装参考 在debian stretch上编译安装ibus-libpinyin(V1.7.3)过程记录

核心思想:

提示缺少啥依赖,就安装啥。

name 的依赖缺少,就找 libname-dev 的包。

其中 libdb4.8-dev 的部分 直接使用 sudo apt install libdb5.3-dev 解决的(mint 18.3)。

关于libpinyin, 在 github 上下源码编译 make 老是报错,最后直接 在此 下载现成的解决的。

libpinyin 使用./autogen.sh --prefix=/usr 加上路径安装。默认在 /usr/local 目录下,自带 share 。装错 直接 rm 删掉即可。


好气,转好后居然不能用。

软件能用坚决不要强行更新

ibus 有个下bug,不能一直显示输入法状态,于是想到更新软件版本解决,从源码编译,麻蛋,一个又一个的依赖缺失,最后make还是失败了。从deb安装,直接提示部分核心组件需要升级,😂,而核心组件的升级除非我升级底层系统。所以最后只好换回原来版本。

---------本文结束感谢阅读---------
Title - Artist
0:00