upgrade-ubuntu-stepped-pit

日常干活用的 mint,特殊情况换到 ubuntu 上干活,一直很烦 窗口关闭按钮一会儿在左边一会儿在右边,考虑到娱乐用的 windows 也在右边,所以看到 ubuntu 18.04 lts 的关闭按钮在右侧,于是有了将 16.04 lts (unity 好像没法设置按钮)升级的想法。

换更新源

之前一直用的 清华的源,毕竟同一个局域网速度快。前几天,大概 5月4日,一直检测不到新版本,于是换了个 阿里云 的,一下检测到新的版本,载了一个多小时,

1
sudo do-release-upgrade -d

参考内容。

期间不能跑,需要选择配置。因为不想继续使用 unity ,所示选择安装 GNOME 3。

重启后,以前的 ctrl + alt + f7 变成了 ctrl + alt + f1

差点吓傻了我,屏幕被放得很大,找了下,发现是 无障碍模式某个都系被打开了,这可能是之前开了大小写指示器的原因所致。

python3.6

python3.5 被升级至 3.6 版本。为什么我关心python版本,应为之前安装 flexget ,官方说是不支援 py3.6,因为2.7还在,所以先 用 pip2 重新安装了 flexget 。正在愁以后是不是要装个虚拟环境 装 3.5,某天再看 flexget 的主页,居然支持 3.6了,balabala……

问题就是 pip 还是 pip3.5 ,而非 3.6 ,

没办法了,一个一个改,使用 find 搜了一下所有 python3.5 的残留相关文件,cd 过去 cat 看看能不能删。最主要的就是 pip3.5 这个也得干掉(sudo apt remove pip3.5),将python 的脚本文件夹/usr/local/lib/python3.5/dist-packages/ 改到3.6,我可不想再一个一个 pip 重装。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
sudo apt remove pip3.5

sudo rm /usr/share/app-install/desktop/python3.5:python3.5.desktop
sudo rm -f/usr/share/app-install/desktop/idle-python3.5:idle-python3.5.desktop
sudo rm -f /usr/share/app-install/desktop/idle-python3.5:idle-python3.5.desktop

sudo rm -r python3.5
sudo rm /var/lib/dpkg/info/python3.5-minimal.list
sudo rm /var/lib/dpkg/info/libpython3.5-minimal:amd64.list

sudo rm -r /usr/local/lib/python3.6 #先看下里面的东西
sudo mv /usr/local/lib/python3.5 /usr/local/lib/python3.6
sudo rm /var/lib/dpkg/info/libpython3.5-minimal:amd64.postrm
sudo rm /var/lib/dpkg/info/python3.5-minimal.postrm
#/home/[username]/.vim/bundle/YouCompleteMe/third_party/ycmd/third_party/JediHTTP/vendor/parso/test/normalizer_issue_files/
# 上面这个不要 remove

sudo apt install python3-pip
sudo pip3 install --upgrade pip

附上 修改 pip 源。

1
2
3
4
5
6
$ cat ~/.pip/pip.conf 
[global]
index-url = https://pypi.tuna.tsinghua.edu.cn/simple
extra-index-url= https://pypi.doubanio.com/simple
[install]
trusted-host=mirrors.aliyun.com

需要自己创建该文件。

---------本文结束感谢阅读---------
Title - Artist
0:00