an-error-in-mpv-player

最近 mpv 突然打不开,终端运行提示 libtalloc 版本有问题。

使用终端运行错误提示如下,

1
2
$ mpv  
mpv: relocation error: /usr/lib/x86_64-linux-gnu/libldb.so.1: symbol talloc_strdup_append_buffer version TALLOC_2.0.2 not defined in file libtalloc.so.2 with link time reference

百度一番,有类似的问题的解决记录。

文档1文档2.

经比较,应该是 libtalloc 有问题。

解决:

1
2
3
sudo apt-get install --reinstall libtevent0 libtalloc2

# 可能只要最后的 libtalloc2 即可

小记。

---------本文结束感谢阅读---------
Title - Artist
0:00